Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Paul Bykov
  Where is Paul Bykov?
 Gelendzhik
 Russia
 Paul Bykov
 Tags
Subject: Is this VFP8 bug or I miss something...
Thread ID: 22254 Message ID: 22254 # Views: 4 # Ratings: 0
Version: Visual FoxPro 8 Category: General VFP Topics
Date: Sunday, April 13, 2003 10:44:57 AM         
   


Hi!

I'm currently trying VFP8 and was stopped by strange behavior of combobox:

In GotFocus:
if this.rowsource = ""
this.rowsourcetype = 6
this.boundcolumn = 2
this.columncount = 2
this.columnwidths = "120,0"
this.columnlines = .F.
this.rowsource = "newport.f_prtnam, id_p"
endif
or you can put this visually - no difference.
All other by default.

After a form started, I can make selection in this combox as always right
(on mouse moving in dropped list selection slides under mouse),
but when I want do the same second time (not closing form),
selection don't slides anymore, on mouse click in row list visually slides,
and as result goes wrong selection... :-(((

My friend made simple form in VFP 7 with this code and all work fine.
When I start the friends' form from VFP 8 all goes bad.

Table contains 1970 records.
When I decrease amount records to about 510 all start working fine.

Is this a bug or I miss something...

WBR, Paul.


COMPLETE THREAD

Is this VFP8 bug or I miss something... Posted by Paul Bykov @ 4/13/2003 10:44:57 AM
RE: Is this VFP8 bug or I miss something... Posted by Paul Brown @ 4/14/2003 10:25:59 AM
RE: Is this VFP8 bug or I miss something... Posted by Paul Bykov @ 4/14/2003 10:53:37 AM
Is this VFP8 bug or I miss something. "Opinion" Posted by Pete Sass @ 4/14/2003 8:58:07 PM
Thank you guys! Solved. Posted by Paul Bykov @ 4/15/2003 7:39:43 AM