Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Paul Gibson
  Where is Paul Gibson?
 United Kingdom
 Paul Gibson
 To: Ken Brown
  Where is Ken Brown?
 Pennsylvania - United States
 Ken Brown
Subject: RE: Citrix grid refresh issue
Thread ID: 373885 Message ID: 373894 # Views: 43 # Ratings: 0
Version: Visual FoxPro 9 SP2 Category: Grids
Date: Thursday, March 28, 2013 4:38:19 PM         

> I have a vfp 9 exe that gets registered as a local com object that works fine on my local network. We released the exe to the client who is running Citrix, when they run the exe they are getting a hit when the program goes to refresh a grid. There are multiple modeless forms that are used in this app. The issue is happening when a user saves data, requeries then refreshes the screen that contains the grid.
> Are there known issues with Citrix and modeless forms and/or grids? I dont have a local Citrix environment so Im not sure how to test debug any of this.

Hi Ken,

I used to work in an application that worked with multiple modeless forms with multiple pages and some of those pages will have had grids on them and we didn't notice any issues at all when some clients ran the application through Citrix. If anything running the application through Citrix, rather than on a standard network, was astonishingly fast in all areas of the application.

The best way I can suggest for testing/debuging is to liaise with your client to see if you can find a way to run your application in their environment with coverage logging switched on, replicate the behaviour you are seeing, exit the application, copy the coverage log file to your machine and then examine the coverage log and see what lines of code are the slowest in the area you are concentrating on and that should give some clues as to what the problem is and then hopefully help find the solution.


Citrix grid refresh issue Posted by Ken Brown @ 3/28/2013 2:44:44 PM
RE: Citrix grid refresh issue Posted by Paul Gibson @ 3/28/2013 4:38:19 PM