Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Erik Hemler
  Where is Erik Hemler?
 Harrisburg
 Pennsylvania - United States
 Erik Hemler
 Tags
Subject: Cursorgetprop not working
Thread ID: 209849 Message ID: 209849 # Views: 1 # Ratings: 0
Version: Visual FoxPro 9 Category: Databases, Tables and SQL Server
Date: Wednesday, December 31, 2008 4:56:23 PM         
   


I've created a view that consists of a main table and two other tables that are joined. The code i've used to create the view is

l_cSelect = "SELECT PL_NAME,FIRMS.FM_DESC,PLANCLAS.PC_TYPE,PL_ID ;
                 FROM SIMS!PLANPRM ;
                 INNER JOIN SIMS!FIRMS ON PLANPRM.FK_FM_ID=FIRMS.FM_ID ;
                 INNER JOIN SIMS!PLANCLAS ON PLANPRM.FK_PC_ID=PLANCLAS.PC_ID ;
                 ORDER BY PL_NAME"
CREATE SQL VIEW ManualEditView AS &l_cSelect
l_cTables = CURSORGETPROP("Tables","ManualEditView")
l_cFieldList = CURSORGETPROP("UpdateNameList","ManualEditView")


The view is working, but when I use the cursorgetprop("Tables") command, it's not returning all the tables included in the view. It's only returning the main table and the first join table. The second join table is not there. All of these table are in the same database.

Also, the "UpdateNameList" property of Cursorgetprop is not working either. This returns the local field names and remote field table + names. It returns the correct values for the fields from the main table and the first joined table, but not the correct values for the field from the second joined table.

Does anyone have any suggestions as to why this is happening?

Thanks in advance,
Erik

ENTIRE THREAD

Cursorgetprop not working Posted by Erik Hemler @ 12/31/2008 4:56:23 PM
RE: Cursorgetprop not working Posted by Mike Yearwood @ 12/31/2008 11:12:45 PM