Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Bernard Bout
  Where is Bernard Bout?
 Brisbane
 Australia
 Bernard Bout
 To: Trevor Watson
  Where is Trevor Watson?
 Barrie
 Canada
 Trevor Watson
 Tags
Subject: RE: Events do not fire in FoxPro v6
Thread ID: 22154 Message ID: 33627 # Views: 1 # Ratings: 0
Version: Visual FoxPro 6 Category: Active X Controls & OLE Automation
Date: Monday, December 01, 2003 2:49:21 AM         
   


I have created many OCX's in VB for use in VFP with no problem. Please send me your OCX code as well as your VFP code so that I can see what you are trying to achieve.



> I am trying to add an ActiveX control that I made in Visual Basic 6 SP5 to a FoxPro program.

> I am able to call the functions and set properties, but the events do not fire.


> I created a test OCX to test the Events in FoxPro, but they do not fire either. The test OCX works in VB 6.0 and VC++ 6.0


>
> I uploaded a copy of the sample OCX to Foxite.com in hopes that somebody would be able to help.

> xd0xdg24.zip

> The functions are
>
> GetInt(ByVal intCode As Integer)
> GetECode(ByVal ECode As EnumItems)
> GetEvent()
>

> The events returned from the program are:
>
> EnumResult(ByVal EI_Result As EnumItems)
> IntegerResult(ByVal intResult As Integer)
> NoResult()
>


ENTIRE THREAD

Events do not fire in FoxPro v6 Posted by Trevor Watson @ 4/10/2003 3:40:18 PM
RE: Events do not fire in FoxPro v6 Posted by Eric den Doop @ 4/10/2003 7:01:23 PM
RE: Events do not fire in FoxPro v6 Posted by Stuart Rosen @ 11/28/2003 7:05:20 AM
RE: Events do not fire in FoxPro v6 Posted by Bernard Bout @ 12/1/2003 2:49:21 AM