Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Stefan Wuebbe
  Where is Stefan Wuebbe?
 Hamburg
 Germany
 Stefan Wuebbe
 To: Cetin Basoz
  Where is Cetin Basoz?
 Izmir
 Turkey
 Cetin Basoz
 Tags
Subject: RE: IntelliSense not Work on Dot
Thread ID: 228297 Message ID: 228346 # Views: 1 # Ratings: 0
Version: Visual FoxPro 9 Category: Projects and Design
Date: Monday, May 18, 2009 12:07:09 PM         
   


> Oh yes it is a little tricky to put it into work but the trick is almost always transparent so I forgot to add details (because the natural expected sequence is the trick itself and doesn't need the TLB loaded):
>
> -Define Excel.Application and make a call to that first (having excel.application and making a call to that is expected action and is the trick for other intellisense)
>
>
local loX as Excel.application, loXS as Excel._Workbook 
> loX. && it is not important if you createobject or not just invoke this one once
> loXS. && now works for workbook

>
> PS: loXS as Excel.Workbook would work the same way. Interesting I didn't notice myself the answer was inwoking excel.application intellisense first (maybe because I don't pay attention to sequence of code which I sort of 'naturally' type). Thanks for making me aware of what I were doing:)
>

Very cool, thanks! :-)

-Stefan

ENTIRE THREAD

IntelliSense not Work on Dot Posted by Khurram Tahir @ 5/18/2009 7:15:27 AM
RE: IntelliSense not Work on Dot Posted by Stefan Wuebbe @ 5/18/2009 9:52:16 AM
RE: IntelliSense not Work on Dot Posted by Ammar Hadi @ 5/18/2009 10:57:27 AM
RE: IntelliSense not Work on Dot Posted by Stefan Wuebbe @ 5/18/2009 11:01:22 AM
RE: IntelliSense not Work on Dot Posted by Ammar Hadi @ 5/18/2009 11:16:28 AM
RE: IntelliSense not Work on Dot Posted by Cetin Basoz @ 5/18/2009 11:05:18 AM
RE: IntelliSense not Work on Dot Posted by Stefan Wuebbe @ 5/18/2009 11:44:11 AM
RE: IntelliSense not Work on Dot Posted by Cetin Basoz @ 5/18/2009 11:56:57 AM
RE: IntelliSense not Work on Dot Posted by Stefan Wuebbe @ 5/18/2009 12:07:09 PM