Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Pete Sass
  Where is Pete Sass?
 Marathon, Ontario
 Canada
 Pete Sass
 To: Chandler Bryan
  Where is Chandler Bryan?
 Lancaster
 South Carolina - United States
 Chandler Bryan
 Tags
Subject: RE: Label Font changes at run time
Thread ID: 394227 Message ID: 394229 # Views: 35 # Ratings: 0
Version: Visual FoxPro 9 SP2 Category: Reports and Printers
Date: Tuesday, December 31, 2013 9:10:51 PM         
   


> This one is surpassingly strange...
>
> My application has been running for years (and years) without any problems such as this one. We recently made some changes in the network environment (Citrix, print server, etc.) We had lots of problems getting our printing sorted out, especially two .lbx formats, a hang tag and a receipt. By juggling drivers and printer settings we have mostly ironed these out, but now we are in a pattern where everything pretty much goes OK except that every day around 1:45 these two labels begin printing crazy. Typically the hangtag will begin to print as a tiny version of itself in the upper left corner of the page - or it will lose track of which printer tray it is supposed to be on, and the receipt font will become enormous and the receipt 4 feet long. This happens more or less simultaneously to multiple locations runnning the application via Citrix. Restarting the application once or twice usually puts things back right. Strangely, only these labels seem to suffer from this; reports (.frx) seem immune
>
> These changes are spontaneous; both labels are inside inside the compiled exe and all locations are running the same executable. We have checked event logs on all the servers involved (Citrix, printserver, dataserver) but see nothing amiss.
>
> I just wonder if anyone has experienced anything like this... ???
>
>
> Chandler


Hi,

Curious issue you are describing. Who knows what may cause this issue??

The obvious things come to my mind.

1. Check scheduled events that could be taking place on the server at the 1:45 PM time period.
I am assuming the print server resides on the Citrix box?
2. Any chance the labels are not running out of the EXE and running externally? If they
where running externally the first thing I would do is go in and make them read-only so nothing
could change them.
3. Have you thought about recreating the labels and recompiling and putting the new exe on a
few workstations and then seeing if the issue goes away for these workstation, but not for others?
4. Have you uninstalled the printer completely and reinstalled fresh drivers. I do mean a complete
uninstall and removal and not using the existing print drivers . . download clean copies and install
these fresh. I would reboot the server after uninstallation of the print drivers prior to reinstalling
the new fresh ones.
5. Last item is the labels using any strange font pack, that is not being used in your .frx normal reports?

That's all that comes to mind right now!

Pete "the IceMan", from the Great White North of Canada.
www.marathongriffincomputers.com

ENTIRE THREAD

Label Font changes at run time Posted by Chandler Bryan @ 12/31/2013 8:31:04 PM
RE: Label Font changes at run time Posted by Pete Sass @ 12/31/2013 9:10:51 PM
RE: Label Font changes at run time Posted by Chandler Bryan @ 12/31/2013 9:23:07 PM
RE: Label Font changes at run time Posted by David Mustakim @ 12/31/2013 9:33:20 PM