Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Chandler Bryan
  Where is Chandler Bryan?
 Lancaster
 South Carolina - United States
 Chandler Bryan
 To: Pete Sass
  Where is Pete Sass?
 Marathon, Ontario
 Canada
 Pete Sass
 Tags
Subject: RE: Label Font changes at run time
Thread ID: 394227 Message ID: 394232 # Views: 34 # Ratings: 0
Version: Visual FoxPro 9 SP2 Category: Reports and Printers
Date: Tuesday, December 31, 2013 9:23:07 PM         
   


> Hi,
>
> Curious issue you are describing. Who knows what may cause this issue??
>
> The obvious things come to my mind.
>
> 1. Check scheduled events that could be taking place on the server at the 1:45 PM time period.
> I am assuming the print server resides on the Citrix box?
> 2. Any chance the labels are not running out of the EXE and running externally? If they
> where running externally the first thing I would do is go in and make them read-only so nothing
> could change them.
> 3. Have you thought about recreating the labels and recompiling and putting the new exe on a
> few workstations and then seeing if the issue goes away for these workstation, but not for others?
> 4. Have you uninstalled the printer completely and reinstalled fresh drivers. I do mean a complete
> uninstall and removal and not using the existing print drivers . . download clean copies and install
> these fresh. I would reboot the server after uninstallation of the print drivers prior to reinstalling
> the new fresh ones.
> 5. Last item is the labels using any strange font pack, that is not being used in your .frx normal reports?
>
> That's all that comes to mind right now!
>
> Pete "the IceMan", from the Great White North of Canada.
> www.marathongriffincomputers.com


Thanks for taking the time Pete... yeah, I've been working with Foxpro since 2.6 for DOS, and I've never seen anyhing like it.

1. Yes, we've checked scheduled tasks on the Citrix server, the print server (separate) and the data server. There's nothing happening then that's not happening at other times during the day.
2. That's a thought... There are copies of the labels living externally that could conceiveably be called... I'll put them somewhere else (though those copies certainly aren't set up with les fonts fou!)
3. The labels work perfectly seven hours a day...if the problem is in the labels themselves there has to be an external event that turns them into Dr. Hyde.
4. I'll forward to my network colleagues.
5. Receipt, no. Hangtag uses a font that's not on reports, but it's a standard TTF font. Good thought though... Maybe I'll use it in a report and see if it's affected.

I do appreciate it...

Chandler

ENTIRE THREAD

Label Font changes at run time Posted by Chandler Bryan @ 12/31/2013 8:31:04 PM
RE: Label Font changes at run time Posted by Pete Sass @ 12/31/2013 9:10:51 PM
RE: Label Font changes at run time Posted by Chandler Bryan @ 12/31/2013 9:23:07 PM
RE: Label Font changes at run time Posted by David Mustakim @ 12/31/2013 9:33:20 PM