Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Mike Gagnon
  Where is Mike Gagnon?
 Pointe Claire
 Canada
 Mike Gagnon
 To: Darren Ward
  Where is Darren Ward?
 Dorset
 United Kingdom
 Darren Ward
 Tags
Subject: RE: MAPI
Thread ID: 78739 Message ID: 78742 # Views: 2 # Ratings: 0
Version: Visual FoxPro 9 Category: Classes and Objects
Date: Friday, October 07, 2005 2:37:56 PM         
   


You mean it is blank? Try this, it works for me VFP.9, XP and outlook 2003

oSession = Createobject("MSMapi.MapiSession")
oMessage = Createobject("MSMapi.MapiMessages")
oSession.LogonUI = .T.
oSession.SignOn
oMessage.SessionID = oSession.SessionID
oMessage.MsgIndex = -1
oMessage.Compose
oMessage.msgsubject = "Attachments sent using FoxPro and MAPI"
oMessage.msgnotetext = "Attached are some test files."
oMessage.Send(.t.) && You will get an error here if you cancel




> Have been running code for ages using the MAPISession and MAPIMessage control without any problems.
>
> But since upgrading all the users to Outlook 2003 I am having problems, I don't seem to be able to populate the body of the message anymore
>
> thisform.olecontrol4.msgNoteText = "This is the email body text"
>
> Has anyone else had a simular problem?


ENTIRE THREAD

MAPI Posted by Darren Ward @ 10/7/2005 12:38:26 PM
RE: MAPI Posted by Mike Gagnon @ 10/7/2005 2:37:56 PM
RE: MAPI Posted by Darren Ward @ 10/7/2005 3:42:51 PM
RE: MAPI Posted by Darren Ward @ 10/7/2005 4:02:56 PM
RE: MAPI Posted by Mike Gagnon @ 10/7/2005 4:39:11 PM
RE: MAPI Posted by Darren Ward @ 10/7/2005 4:57:16 PM
RE: MAPI Posted by Mike Gagnon @ 10/7/2005 5:11:49 PM