Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Stefan Wuebbe
  Where is Stefan Wuebbe?
 Stefan Wuebbe
 To: Barry Cox
  Where is Barry Cox?
 New Zealand
 Barry Cox
Thread ID: 416123 Message ID: 416128 # Views: 64 # Ratings: 2
Version: Visual FoxPro 9 SP2 Category: General VFP Topics
Date: Monday, December 22, 2014 9:42:44 AM         

> Sorry to be a nuisance, but I had to reload my system (win 7) and also vfp 9.0. Unfortunately I cant remember where to get the above file which is asked for on starting vfp.
> Thanks in advance


MSXML 4 is considered to be "obsolete" though, MS support ended in April 2014.
See also http://en.wikipedia.org/wiki/MSXML

And while IDE -> Tools -> Task Pane does need it, you can turn its auto start off in the top node of its "options".
The only runtime thing that needs MSXML 4 is the XmlAdapter class if I remember correctly.

If you are using the XmlDOM COM class at runtime, its version "4.0" exists only when MSXML 4 is explicitly installed.
But the current version, or its backwards-compatibility part, works for me on newer O/S versions:
oXml = CREATEOBJECT("MSXML2.DOMDocument.4.0") && works in WinXP anyway, and later only when MSXML4 is explicitly installed
oXml = CREATEOBJECT("MSXML2.DOMDocument") && works on Win 7, 8, 10 Preview, no "MSXML4" required



MSXML2.DOMDOCUMENT.4.0 Posted by Barry Cox @ 12/22/2014 7:42:44 AM
RE: MSXML2.DOMDOCUMENT.4.0 Posted by Stefan Wuebbe @ 12/22/2014 9:42:44 AM
RE: MSXML2.DOMDOCUMENT.4.0 Posted by Paul Gibson @ 12/22/2014 10:42:25 AM
RE: MSXML2.DOMDOCUMENT.4.0 Posted by Barry Cox @ 12/23/2014 3:58:32 AM
RE: MSXML2.DOMDOCUMENT.4.0 Posted by Barry Cox @ 12/23/2014 3:57:59 AM