Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Paul Culbertson
  Where is Paul Culbertson?
 Katy
 Texas - United States
 Paul Culbertson
 To: Ryss Unger
  Where is Ryss Unger?
 Cape Town
 South Africa
 Ryss Unger
 Tags
Subject: RE: Possible bug with GetTimeZoneInformation WinAPI call
Thread ID: 505 Message ID: 525 # Views: 2 # Ratings: 0
Version: Unknown Category: General VFP Topics
Date: Sunday, June 03, 2001 11:44:14 PM         
   


> > On all of the machines we have in our office, the GetTimeZoneInformation returns the wrong startdate.
> >
> > I am in Central Standard Time (-6 GMT)
> > and it returns 10 month 5 day as the standard time starting day for this year. Is there a bug in windows, as it stores it in the registry and in the win.ini file for the MAPI controls the same way.
> >
> > DECLARE INTEGER GetTimeZoneInformation IN kernel32 STRING @TZInfo
> >
> > Thanks,
> >
> > Paul Culbertson
> >
> > Home of the Visual FoxPro Experts
> >
> > Houston, TX
> >
> Hi Paul
> In working thru MSDN for our Foxite.com FAQ presenation I have picked up the following links whcih may help.
>
> http://support.microsoft.com/support/kb/articles/Q188/8/97.asp
> http://support.microsoft.com/support/kb/articles/Q177/1/46.asp
>
> Hope these help
>
> Regards
> Ryss

Thanks Ryss, I will look at them a little more closely in the morning...the first link looks like it is more of what I was looking for. I can't remember where I found out, after I posted this question, that the 05 represented the DOW not the actual day of the month.

Paul Culbertson

Home of the Visual FoxPro Experts

Houston, TX


ENTIRE THREAD

Possible bug with GetTimeZoneInformation WinAPI call Posted by Paul Culbertson @ 6/1/2001 4:11:49 PM
RE: Possible bug with GetTimeZoneInformation WinAPI call Posted by Ryss Unger @ 6/1/2001 4:28:53 PM
RE: Possible bug with GetTimeZoneInformation WinAPI call Posted by Paul Culbertson @ 6/3/2001 11:44:14 PM