Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Robert Volmer
  Where is Robert Volmer?
 Forney
 Texas - United States
 Robert Volmer
 Tags
Subject: REPORTOUTPUT fails to create HTML
Thread ID: 143085 Message ID: 143085 # Views: 1 # Ratings: 0
Version: Visual FoxPro 9 Category: Reports and Printers
Date: Friday, August 24, 2007 5:47:29 PM         
   


Hello,

Hopefully someone can help me on this problem, I am trying to convert a report to html so it can be sent via email.
The code looks something like this:

_REPORTOUTPUT = oapp.cProgramDirectory+"ReportOutput.app"

LoRepListener = .NULL.
MESSAGEBOX(_reportoutput)
DO (_reportoutput) WITH 5, LoRepListener
LoRepListener.TargetFileName = oApp.cDataDirectory + 'body.htm'
LoRepListener.QuietMode = .T.
REPORT FORM (THIS.oReportToUse) OBJECT LoRepListener
LoRepListener = .NULL.

This works flawlessly in the compiled exe on the the dev machine and on seperate systems running Windows XP PRO SP2,
Windows 2K, Windows 2K with SP4, BUT fails on a system with Windows 2K SP2. What gives? The body.htm would be created
but would be empty. The Messagebox was put there for me to make sure i didn't forget to distribute the ReportOutput.app

Any help or insight would be appreciated,

Robert Volmer
"Whoa, slow down there, maestro. There’s a *New* Mexico?"

ENTIRE THREAD

REPORTOUTPUT fails to create HTML Posted by Robert Volmer @ 8/24/2007 5:47:29 PM
RE: REPORTOUTPUT fails to create HTML Posted by Barbara Peisch @ 8/24/2007 8:46:26 PM
RE: REPORTOUTPUT fails to create HTML Posted by Robert Volmer @ 8/25/2007 3:13:29 AM
RE: REPORTOUTPUT fails to create HTML Posted by Barbara Peisch @ 8/25/2007 4:57:57 AM
RE: REPORTOUTPUT fails to create HTML Posted by Yull67 @ 8/25/2007 1:52:58 AM
RE: REPORTOUTPUT fails to create HTML Posted by Robert Volmer @ 8/27/2007 2:52:39 PM