Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Craig Boyd
  Where is Craig Boyd?
 Forest Lake
 Minnesota - United States
 Craig Boyd
 To: Eric den Doop
  Where is Eric den Doop?
 Houten
 Netherlands
 Eric den Doop
 Tags
Subject: RE: Reproducable problem!
Thread ID: 40195 Message ID: 53449 # Views: 9 # Ratings: 0
Version: Visual FoxPro 8 Category: Classes and Objects
Date: Wednesday, October 13, 2004 4:37:45 AM         
   


Was there a solution found to this? It makes the class fairly unuseable without some kind of workaround. I just ran into this myself, and while I may decide to switch back to the bbsystray.dll in order to get my app out the door, I find it a little hard to just leave a problem like this unsolved. It doesn't make much sense. Even if you call removeiconfromsystray method and then addicontosystray the icon it still doesn't begin responding again until the entire process is terminated and restarted. I'll try a few more things and see what I come up with, but this is the only discussion about this issue that I've yet found on the net...so I thought I would see if anyone has had any luck working around this bug.

> OK, I now know how to reproduce this problem. Here's the code to create the environment: it creates a form, a main prg, a project and then builds and runs the EXE. The app will hang if you:
> - single click the tray icon
> - move the mouse over the shortcut menu items (starting at the bottom)
> - click empty area in the desktop to release menu
> --> after that, the shortcut menu nolonger appears when I click on the icon.




ENTIRE THREAD

systray icon does not respond Posted by Rajani @ 3/31/2004 7:36:31 AM
RE: systray icon does not respond Posted by Eric den Doop @ 4/1/2004 8:59:25 AM
RE: systray icon does not respond Posted by Rajani @ 4/2/2004 3:57:18 AM
RE: systray icon does not respond Posted by Eric den Doop @ 4/8/2004 7:39:03 AM
RE: systray icon does not respond Posted by Rajani @ 4/13/2004 5:31:44 AM
RE: systray icon does not respond Posted by Eric den Doop @ 4/13/2004 4:20:23 PM
RE: systray icon does not respond Posted by Rajani @ 4/13/2004 11:18:47 PM
I'm facing the same problem :-( Posted by Handi Rusli @ 4/15/2004 6:31:41 AM
Reproducable problem! Posted by Eric den Doop @ 4/15/2004 3:19:30 PM
RE: Reproducable problem! Posted by Rajani @ 4/16/2004 1:22:04 AM
RE: Reproducable problem! Posted by Steve Supinski @ 5/17/2004 11:31:01 PM
RE: Reproducable problem! Posted by Eric den Doop @ 5/18/2004 12:11:00 AM
RE: Reproducable problem! Posted by Steve Supinski @ 5/18/2004 12:49:34 AM
RE: Reproducable problem! Posted by liquid_picnic anon @ 10/13/2004 4:37:45 AM
Additional Information Posted by Craig Boyd @ 10/13/2004 5:41:46 AM
Any Solution to this? Posted by Ken Blum @ 12/23/2004 5:25:36 PM
RE: Any Solution to this? Posted by Eric den Doop @ 12/23/2004 10:44:24 PM
RE: Any Solution to this? Posted by Ryan Hinton @ 12/24/2004 9:43:54 AM
RE: Any Solution to this? Posted by Eric den Doop @ 12/24/2004 11:34:30 AM
RE: Any Solution to this? Posted by Ken Blum @ 12/29/2004 2:03:24 PM
RE: systray icon does not respond Posted by Jagdish Angre @ 2/6/2008 1:00:17 AM