Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Borislav Borissov
  Where is Borislav Borissov?
 Sofia
 Bulgaria
 Borislav Borissov
 To: FRED QUAYE
  Where is FRED QUAYE?
 
 Ghana
 FRED QUAYE
 Tags
Subject: RE: Seek Function behaving strangely
Thread ID: 104663 Message ID: 104664 # Views: 1 # Ratings: 0
Version: Visual FoxPro 6 Category: Errors & Debugging
Date: Friday, August 18, 2006 8:19:51 PM         
   


> This is really strange. I have a text box , with recordsoure = None.
>
> If a user inputs data there is a routine which checks as to whether that
> code exists. Surely to check for duplicates, however the search results for duplicates is just not working.
>
> The search routine I've placed in the lostfocus of the text box
>
> Use result order res_code
> seek alltrim(thisform.text1.value)
>
>
if found()

> Message ............duplicate record found
>
>
else

>
>
>
endif

>
>
> If I put in a duplicate, it just ignores the test routine in the text b
> ox.
>
> Wkat I'm I doing wrong? This is a very simple search, so I'm even amazed
> at the outcome


What is the index expression of the current tag?
What is SET EXACT setting?



Borislav Borissov



ENTIRE THREAD

Seek Function behaving strangely Posted by FRED QUAYE @ 8/18/2006 8:16:34 PM
RE: Seek Function behaving strangely Posted by Borislav Borissov @ 8/18/2006 8:19:51 PM
RE: Seek Function behaving strangely Posted by Brad Schulz @ 8/18/2006 8:26:18 PM
RE: Seek Function behaving strangely Posted by Ken Murphy @ 8/18/2006 8:57:07 PM