Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Jamie Osborn
  Where is Jamie Osborn?
 Melbourne
 Australia
 Jamie Osborn
 To: Manisha Sathe
  Where is Manisha Sathe?
 
 Singapore
 Manisha Sathe
 Tags
Subject: RE: Set deleted ON problem again
Thread ID: 33701 Message ID: 33706 # Views: 1 # Ratings: 0
Version: Visual FoxPro 8 Category: Forms
Date: Tuesday, December 02, 2003 7:42:28 AM         
   


> In my previous post i had posted problem about set deleted on - when using private data session. Then i got the answer that i need to set it inside form load event so that each instance can understand that.
>
> it worked for the single table, now facing again the same problem for multi table form. i have a parent (on top) and child (in a grid), when i issue delete, i am deleting both parent / child records and i do not see these recs again on screen (i.e set deleted on is working )
>
> But when i rerun the same form again, then i see parent record (deleted one) but i do not see but corresponding child records (deleted) i.e set deleted on is working for child but not parent, whether it means that i need to select each table and say set deleted on ? I have many tables such as settings / customer - which are related to this form, what's the main problem cause and how can i solve it ?
>
> regards,
> manisha
>
> manisha
>
>
>
>
>
No. SET DELETED ON is scoped for the entire datasession - not just one table. I'd look elsewhere for your problem.

Cheers,
Jamie
jamie.osborn@foxite.com

ENTIRE THREAD

Set deleted ON problem again Posted by Manisha Sathe @ 12/2/2003 5:03:39 AM
RE: Set deleted ON problem again Posted by Jamie Osborn @ 12/2/2003 7:42:28 AM
RE: Set deleted ON problem again Posted by Manisha Sathe @ 12/2/2003 3:12:09 PM
RE: Set deleted ON problem again Posted by ed fabonan @ 12/3/2003 1:22:20 AM
Thanks Posted by Manisha Sathe @ 12/3/2003 10:32:04 AM