Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Andy Kramek
  Where is Andy Kramek?
 Hot Springs Village
 Arkansas - United States
 Andy Kramek
 To: Ken Murphy
  Where is Ken Murphy?
 Springhill
 Canada
 Ken Murphy
 Tags
Subject: RE: Strange error
Thread ID: 104017 Message ID: 104054 # Views: 1 # Ratings: 0
Version: Visual FoxPro 9 Category: Errors & Debugging
Date: Thursday, August 10, 2006 11:15:31 PM         
   


> One of the search types that I have is "ChildID." This searches for the childID assigned at the project (not the child record ID field.) The child ID has an input mask of [!!!9999999] and there is an index on the ChildID field. When I populate the candidate list, I use a SEEK()/SCAN WHILE construct. A user enters "ABC" and the app will find all of the chidren where the child ID starts with "ABC" - so far all works well. The users are now entering child records with a child ID starting with YPK. If the ChildID index is set, YPK1041 is the last child record. When I enter YPK into the search text box, the candidate list fills appropriately, it automatically .Click()s and the child information is displayed but at this point, and only on this record, the app tells me that it cannot SEEK() that child's project or sub-project. If I then click child YPK1040 the app works perfectly. If I again, click child YPK1041, the SEEK()s on project and sub-project work perfectly. If I go back up to the searchtext and enter YPK again, the SEEK()s fail again.
>
> My first thought was "there has to be a data problem." I compaired YPK1040 to YPK1041 and found that the project and subproject ID's were identical in both child records. I add a new child record, YPK1042. Now YPK1041 works perfectly and YPK1042 has the error.
>
> Worse still, this code has not changed in 18 months and this error just showed up this week. I KNOW this code works. As any body else run into problems with "the last logical record for that index?"


Since you say the code hasn't changed, what about the environment?

This sounds awfully like a row buffering issue to me! Are you sure you have committed the record before the SEEK() (about the only way I can see why the 'last' record would fail would be if it weren't actually saved yet)

Regards
Andy Kramek
Microsoft MVP (Visual FoxPro)
Tightline Computers Inc, Akron Ohio, USA

ENTIRE THREAD

Strange error Posted by Ken Murphy @ 8/10/2006 8:18:29 PM
RE: Strange error Posted by Pete Sass @ 8/10/2006 9:37:39 PM
RE: Strange error Posted by Ken Murphy @ 8/10/2006 10:32:45 PM
RE: Strange error Posted by Joselito Watiwat @ 8/14/2006 7:32:51 AM
RE: Strange error Posted by Sergey Karimov @ 8/10/2006 9:38:33 PM
RE: Strange error Posted by Ken Murphy @ 8/10/2006 10:44:39 PM
RE: Strange error Posted by Sergey Karimov @ 8/10/2006 11:25:40 PM
RE: Strange error Posted by Ken Murphy @ 8/11/2006 1:33:41 AM
RE: Strange error Posted by Andy Kramek @ 8/10/2006 11:15:31 PM
RE: Strange error Posted by Ken Murphy @ 8/11/2006 1:47:56 AM
RE: Strange error Posted by Andy Kramek @ 8/11/2006 11:34:21 AM
RE: Strange error Posted by Ken Murphy @ 8/11/2006 12:02:50 PM
RE: Strange error Posted by Pete Sass @ 8/16/2006 10:21:42 PM
RE: Strange error Posted by Ken Murphy @ 8/17/2006 1:53:54 AM
RE: Strange error Posted by Ken Murphy @ 8/21/2006 7:06:31 PM
RE: Strange error Posted by David Hall @ 8/23/2006 12:06:06 PM
RE: Strange error Posted by Ken Murphy @ 8/23/2006 2:45:16 PM
RE: Strange error Posted by David Hall @ 8/31/2006 5:38:45 PM
RE: Strange error Posted by Ken Murphy @ 8/31/2006 6:17:39 PM
RE: Strange error Posted by Jim Winter @ 8/31/2006 6:44:57 PM
RE: Strange error Posted by tushar @ 8/31/2006 7:06:07 PM
RE: Strange error Posted by Ken Murphy @ 8/31/2006 7:41:37 PM
RE: Strange error Posted by tushar @ 8/31/2006 7:46:59 PM
RE: Strange error Posted by Ken Murphy @ 8/31/2006 8:11:52 PM
RE: Strange error Posted by tushar @ 8/31/2006 9:05:03 PM
RE: Strange error Posted by Jim Winter @ 8/23/2006 3:30:45 PM
RE: Strange error Posted by David Hall @ 9/11/2006 4:19:02 PM
RE: Strange error Posted by Ken Murphy @ 9/11/2006 4:35:59 PM
RE: Strange error Posted by David Hall @ 9/12/2006 11:10:28 AM