Welcome To The Home Of The Visual FoxPro Experts  
home. signup. forum. archives. search. google. articles. downloads. faq. members. weblogs. file info. rss.
 From: Ilya Rabyy
  Where is Ilya Rabyy?
 Fountain Valley
 California - United States
 Ilya Rabyy
 To: suhas hegde
  Where is suhas hegde?
 sirsi
 India
 suhas hegde
 Tags
Subject: RE: Trouble with LPARAMETERS
Thread ID: 155164 Message ID: 155171 # Views: 1 # Ratings: 1
Version: Visual FoxPro 9 Category: General VFP Topics
Date: Wednesday, December 26, 2007 7:02:32 PM         
   


> > Colleagues,
> >
> > either I'm getting senile, have lost any sense and miss/forget something profoundly basic in programming,...
> > ... or there are again some gremlins messing with my machine!
> >
> > Coz I can't recall ever seeing LPARAMETERS (neither PARAMETERS) behave like the following:
> >
> > - I've got a PRG, which I run off the Command window;
> >
> > - This PRG's first line is
LPARAMETERS tcParam, tdParam1, tdParam2

> > and I put SET STEP ON after this line;
> >
> > - I do, off the Command window
SET PROC TO [FullPath2MyProc\MyProc.PRG]

> > - and then
=MyProc(SomeString, {^2000/01/01}, {^20078/01/01})

> > ... and when it stops in debugging mode - ain't no none of them PARAMETERS is listed in the Locals window in Debugger - ?!?!?!?! (And, of course, the rest of the program behaves accordingly coz I ain't no fool and took precautions just for such case, i.e IF VARTYPE(tcParam1) # "C" etc.)
> >
> > So, does anyone here have any idea why the bleep my PARAMETERS are getting lost?
> >
> > AHWBGA!
> >
> > Regards,
> >
> > Ilya
>
>
> hi,
> happend to me earlier but in mycase i deleted the .fxp for vfp to recmpile and use the latest code
>
> Thanx
> suhashegde

Tried that, same result...

... and then I noticed CLEAR ALL command... No wonder those parameters are being wiped out! (Told you I'm getting senile!)

Sorry, colleagues, for wasting your time on my stupid mistake! My bad!

And thank you all for trying to help this old poor senile Grandpapa of twins! ((:>))

Regards,

Ilya

ENTIRE THREAD

Trouble with LPARAMETERS Posted by Ilya Rabyy @ 12/26/2007 6:10:40 PM
RE: Trouble with LPARAMETERS Posted by Cetin Basoz @ 12/26/2007 6:26:19 PM
RE: Trouble with LPARAMETERS Posted by Ilya Rabyy @ 12/26/2007 6:40:15 PM
RE: Trouble with LPARAMETERS Posted by suhas hegde @ 12/26/2007 6:45:31 PM
RE: Trouble with LPARAMETERS Posted by Ilya Rabyy @ 12/26/2007 7:02:32 PM